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ABSTRACT 
 
 

Extending the Utility of Machine Based Height Sensors 

to Spatially Monitor Cotton Growth.  (May 2004) 

David William Geiger, B.S., Iowa State University 

Chair of Advisory Committee: Dr. Stephen W. Searcy 
 
 

The recommended procedures for implementing COTMAN; a cotton 

management expert system; suggest frequent crop scouting at numerous locations for 

each field.  Machine based height sensors coupled with the ability to spatially record 

height values make it possible to locate regions of a field that are height representative of 

the entire field.  A machine based height measurement system called HMAP was used to 

assess plant height in various fields in the 2003 growing season while the same fields 

were monitored with COTMAN.  The plant height data was used to determine an 

optimal COTMAN sampling scheme for each field consisting of significantly fewer 

sampling locations than recommended by COTMAN.  It was possible to ascertain 

equivalent information from COTMAN using two sites selected from height data in 

place of six sites selected per COTMAN recommendations.  The HMAP system was 

extended to monitor rate of growth in real time in addition to plant height by comparing 

historical plant height data recorded on previous field passes to current height values.  

The rate of growth capable HMAP system will make it possible to track cotton growth 

and development with an automated system.   



 iv

ACKNOWLEDGEMENTS 
 
 
 
Support from the following sponsors made this research possible: John Deere 

AMS of Ankeny, Iowa; Cotton Incorporated of Cary, North Carolina; Texas Agricultural 

Experiment Station in College Station, Texas; and Texas Cooperative Extension in 

College Station, Texas.  Field support and technical advice for COTMAN from Dan 

Fromme (IPM Agent, Wharton County) was greatly appreciated. 

To the Department of Biological and Agricultural Engineering at Texas A&M  

University and my advisor Dr. Stephen Searcy, thank you for the opportunity to 

participate in a top notch program at a world class facility.  Thank you to my family and 

friends who have supported me during my entire educational career and waited patiently 

for me to complete this chapter of my life. 



 v

TABLE OF CONTENTS 
 
 
 
 Page 
 
ABSTRACT ...........................................................................................................  iii 
 
ACKNOWLEDGEMENTS ...................................................................................  iv 
 
TABLE OF CONTENTS .......................................................................................  v 
 
LIST OF FIGURES................................................................................................  vii 
 
LIST OF TABLES .................................................................................................  viii 
 
INTRODUCTION..................................................................................................  1 
 

Background ...............................................................................................  1 
Rationale and Significance ........................................................................  4 
Objectives ..................................................................................................  9 

 
PRECISION AGRICULTURE: AN INPUT FOR COTMAN ..............................  10 
 

Introduction ................................................................................................  10 
Materials and Methods ...............................................................................  13 
Results and Conclusions.............................................................................  20 
Additional Details ......................................................................................  26 

 
RECOMMENDATIONS FOR FUTURE COTMAN RESEARCH......................  30 
 
REAL TIME RATE OF GROWTH DETERMINATION ....................................  32 
 

Introduction ................................................................................................  32 
Materials and Methods ...............................................................................  34 
Results and Conclusions.............................................................................  43 

 
RECOMMENDATIONS FOR FUTURE RATE OF GROWTH RESEARCH....  47 
 
SUMMARY AND CONCLUSIONS.....................................................................  49 
 

Summary ....................................................................................................  49 
 
Conclusions ................................................................................................  50 



 vi

  Page 
 
REFERENCES.......................................................................................................  51 
 
APPENDIX A ........................................................................................................  54 
 
APPENDIX B ........................................................................................................  65 
 
VITA ......................................................................................................................  70 



 vii

LIST OF FIGURES 
 
 
 

 FIGURE  Page 
 
 1 2003 COTMAN Sampling Locations ..................................................  14 
 
 2 NIR and NDVI Maps ...........................................................................  17 
 
 3 Plant Height Maps Created From HMAP Data ...................................  18 
 
 4 Average Height Locations and Regions...............................................  19 
 
 5 Rate of Growth Map.............................................................................  21 
 
 6 NAFS/NAWF Development Curves for Irrigated Sites.......................  22 
 
 7 Basic Components of the HMAP System ............................................  26 
 
 8 Serial "Y" Cable Wiring Diagram and Pin Assignments .....................  36 
 
 9 Test Course Setup.................................................................................  41 



 viii

LIST OF TABLES 
 
 
 
 TABLE  Page 
 
 1 Comparison of COTMAN Sampling Schemes ....................................  5 
 
 2 Standard Deviation of 2003 Plant Height Data (cm) ...........................  21 
 
 3 HMAP System Height Measurement Component Summary...............  27 
 
 4 Summary of Additional Components Added to HMAP for ROG 
  Determination ......................................................................................  35 
 
 5 Raven Strings Used by HMAP ............................................................  38 
 
 6 Summary of Height Change Detection Error Analysis .......................  45 
 
 7 Significance Value Summary from Games-Howell Test ....................  46 



 1

INTRODUCTION 
 
 
 
BACKGROUND 
 

In the lean farm economy that is reality today, profitability is dependent on sound 

management decisions.  Agronomists at the University of Arkansas developed an expert 

management software package called COTMAN to aid cotton producers in making 

important management decisions. COTMAN uses a combination of field observations, 

plant mapping, and meteorological data to track the physiological development of cotton 

throughout the growing season.  COTMAN has become an important management tool 

for both researchers and cotton producers.  While it is a powerful and proven tool, there 

are still opportunities to enhance the value it provides.   

First, COTMAN is a field scale management system.  Crop scouting is conducted at 

various locations throughout the field in order to obtain a cross section of samples that 

characterize the general or average condition of the field.  Many management factors 

such as requirements for irrigation, insect control, plant growth regulators (PGRs) such 

as mepiquat chloride (PIX®), and defoliants can vary significantly across the field.  

Management zones are often restricted to the farm or field level due to a lack of data 

which can be used to identify smaller management zones.  Second, selection of sampling 

locations by crop scouts is a highly subjective process that does not always result in 

sampling locations that realistically characterize the field.  While crop scouts may 

attempt to select samples representative of the field, it is difficult for even the most  

_______________ 
This thesis follows the style and format of Applied Engineering in Agriculture.   
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experienced scouts to select samples that realistically represent the population of the 

field.  Third, COTMAN requires frequent in-field data collection which is time 

consuming and labor intensive.  Over the course of the season, such investments become 

substantial.  Reducing the manual inputs required for COTMAN provides an opportunity 

to lower the costs associated with implementing COTMAN while maintaining the 

management value.  Precision agriculture data sources such as plant height maps, yield 

maps, and aerial imagery could provide a means to more accurately assess field 

conditions by selecting better sampling locations and decrease the costs associated with 

implementation by minimizing field sampling requirements. 

Expert management systems such as COTMAN and crop modeling systems such as 

GOSSYM attempt to monitor and predict, respectively, the effects of management 

decisions on cotton development. While both systems track a variety of parameters 

associated with the physiological development of cotton, they are ultimately tracking/ 

modeling aspects of crop growth rate.  A variety of measures of crop growth rate have 

been proposed.  COTMAN tracks nodes above first square (NAFS) and nodes above 

white flower (NAWF) relative to a target development curve based on accumulated heat 

units and historical meteorological data.  Plant height is another parameter that can be 

used to track crop growth rate.  Plant height over time or rate of growth directly creates a 

measure of crop growth rate with respect to plant height.  Researchers have developed 

empirical relationships between cotton plant height and plant biomass.  By correlating 

plant height to plant biomass, it is possible to generate another measure of crop growth 

rate with respect to biomass.  A Texas A&M University (TAMU) developed machine 
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based spatial height mapping system known as HMAP has the ability to spatially record 

plant height across a field and adjust plant growth regulator application rates in real time 

based on empirical relationships between plant height and biomass developed by 

agronomists.  Spatial height data or biomass data recorded with the HMAP system can 

be used to monitor crop growth rate with respect to plant height and biomass.  By 

comparing current HMAP height data with historical height data recorded on previous 

field passes it becomes possible to directly monitor crop growth rate.  While plant height 

data from different dates can be collected and post-processed using a variety of methods, 

the HMAP system provides a unique opportunity to collect and process data in real time. 

Agricultural equipment performing routine field operations provides a valuable 

opportunity to observe crop.  Precision farming technologies have made data collection 

operations such as yield mapping during harvest commonplace; however, data is not 

collected during the majority of non-harvest operations.  A lack of commercially 

available data collection equipment for non-harvest operations and a lack of decision 

support systems to translate field observations into management decisions both 

contribute to the limited utility of collecting such data.  In cotton, frequent applications 

of chemicals such as insecticides and plant growth regulators provide an opportunity for 

data collection during routine spraying operations throughout the season.  The HMAP 

system integrated with MEPRT, a software application used to determine plant growth 

regulator application rates and timing, uses plant height data along with other pre-

defined parameters such as row spacing and plant density to spatially vary plant growth 

regulator application rates in real time.  Real time variable rate application (VRA) of 
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plant growth regulator provides more effective utilization of chemicals than traditional 

constant rate methods by spatially targeting plants with the greatest need for PGRs, 

however, research has shown that total chemical use efficiency and lint yield are 

virtually unaltered.  In the current HMAP system, tall plants always receive the highest 

application rate without regard for the effects of previous applications.  Plant growth 

regulator usage could potentially be reduced by considering rate of growth in addition to 

plant height when calculating application rates.  Rather than targeting all tall plants with 

the highest application rate, only tall plants that are vigorously growing would be 

targeted with the highest rate thereby reducing overall PGR usage by not applying 

excess PGR on plants where the rate of vegetative growth was already reduced by 

previous PGR applications or other factors that can limit growth. 

 

RATIONALE AND SIGNIFICANCE 

COTMAN is a software based expert system that interprets in-season data to detect 

plant stress, monitor plant development, and aid in scheduling end-of-season activities 

such as insecticide termination and harvest initiation (Bourland et al., 1994).  Growth 

curves generated by COTMAN can be used to quickly identify potential problems (Klein 

et al., 1994).  Oosterhuis et al. (1996) determined through research in Arkansas that the 

cost savings from using COTMAN for timing insecticide termination alone would result 

in savings between $14.13/hectare and $63.70/hectare ($5.72/acre and $25.78/acre) 

depending on region.  The benefits of COTMAN are clear; however, intensive manual 

data collection has hindered acceptance by producers, and many that do use it cut 
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corners by not collecting the data in the quantity or frequency recommended by 

COTMAN.  Cochran et al. (1999) addressed long standing concerns regarding 

appropriate sampling schemes for COTMAN.  They determined that increasing the 

number of sampling sites over COTMAN recommendations has significantly less effect 

than increasing the number of plants sampled at each site.  The study determined optimal 

sampling schemes for various parameters; a comparison of COTMAN recommendations 

and the optimized scheme is summarized in Table 1. 

Table 1: Comparison of COTMAN Sampling Schemes 

 COTMAN Optimized 
4-8 sites 5-11 sites Plant Height 
2 measures per site 2-4 measures per site 
4-8 sites 3-10 sites Squaring Nodes 
10 plants per site 7-14 plants per site 
4-8 sites 2-7 sites Square Relation 
10 plants per site 11-27 plants 
4-8 sites 3-8 sites NAWF 
10 plants per site 7-23 plants per site 

 
 
Stewart et al. (2000) concluded through a study in North Carolina that the time inputs 

of COTMAN were excessive for the type of information received.  They pointed out that 

in North Carolina the average cotton field size is 5.7 hectares (14.2 acres) which requires 

four sampling sites per COTMAN recommendations.   

More careful consideration of sampling locations could offer added value to 

COTMAN by more efficiently and accurately assessing field conditions.  Various 

studies have been conducted to estimate the costs associated with implementing 

COTMAN when using COTMAN sampling recommendations.  Robertson et al. (1997) 

determined that the direct cost of sampling for once weekly COTMAN scouting ranged 
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from $3.14/hectare to $4.32/hectare ($1.27/acre to $1.75/acre) and $8.62/hectare 

($3.49/acre) for twice weekly monitoring.  Teague et al. (2000) determined that time 

requirement for each 4.0 hectares (10 acres) of field size of 12 minutes per sampling.  

Assuming the same labor parameters as the Robertson et al. study (10 weeks, 

$7.00/hour), this roughly correlates to $3.46/hectare ($1.40/acre) for once weekly and 

$6.92/hectare ($2.80/acre) for twice weekly scouting neglecting travel and management 

costs assumed in the Robertson et al. study.  The results of these studies are comparable.    

While the benefits of COTMAN undoubtedly outweigh the costs associated with 

implementation, the costs are significant and could be reduced if field scouting 

requirements were reduced.  The HMAP system developed by Searcy and Beck (2000) 

provides an opportunity to reduce the number of sampling locations needed to 

characterize the general condition of a field by spatially identifying locations in the field 

that realistically represent the average conditions present.  COTMAN generates 

development curves to track cotton development and crop growth rate relative to an ideal 

curve. Further enhancements of the HMAP system such as rate of growth determination 

may also provide opportunities to reduce the frequency of COTMAN field sampling 

through automated monitoring of crop development.  Similar developmental information 

could be ascertained from rate of growth data by comparing actual rate of growth to an 

ideal rate of growth model.  Kennedy and Hutchinson (2001) concluded that lint yield 

was correlated to early season crop growth rate, in particular, height.  The HMAP system 

could monitor such parameters without crop scouting while providing the same look-

ahead knowledge to the producer.  An extended HMAP system with the ability to 
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monitor and record rate of growth in addition to plant height could also enhance many 

management decisions outside of COTMAN by providing an inexpensive means through 

which crop growth rate could be evaluated.  

Lint yield and quality are maximized when the number of open bolls present at 

harvest is maximized.  This is achieved when an optimum balance between vegetative 

and reproductive growth is maintained (Kerby et al., 1990; Kerby et al., 1997).  Plant 

growth regulators such as PIX® are used to slow vegetative growth (Fernandez et al., 

1992; Kerby et al., 1982; Reddy et al., 1990; Reddy et al., 1992; Stuart et al., 1984; 

York, 1983; Zummo et al., 1984) and thereby maintain such a balance.  A study by 

Cothren (1979) indicated that PIX® usage could increase the number of harvestable 

bolls.  Bourland and Watson (1990) and Kerby et al. (1986) showed in separate studies 

that mepiquat chloride causes a redistribution of bolls away from the main stem, 

possibly to more accessible harvesting locations while the total number of bolls remains 

constant.  The effects of PIX® on yield have been inconsistent (Kerby et al., 1986); 

however, other benefits such as improved water and carbon efficiency have been well 

documented (Fernandez et al., 1992).   

Weir et al. (1991) concluded that lint yield can be improved through the use of 

constant rate PIX® application throughout the growing season.  Variable rate plant 

growth regulator application offers an approach that addresses field variability by 

targeting taller plants with more plant growth regulator than shorter plants.  Research 

efforts by Munier et al. (1994) with operator controlled VRA based on visual assessment 

of plant height and by Beck (2001) with real time variable rate application based on 
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machine measured plant heights have also produced mixed results.  In some trials yield 

was increased by variable rate application; however, yield affects between variable rate 

application and constant rate application were generally inconclusive. Thurman and 

Heiniger (1999) concluded that constant rate PIX® application actually increases spatial 

variability with respect to plant height and height to node ratio.  This phenomenon 

suggests that management practices which directly address spatial variability such as 

variable rate PIX® application could be used to reduce spatial variability while still 

realizing the benefits of cotton PGRs.  The Munier et al. (1994) VRA system relied on 

operator interpretation of chains hanging from the sprayer indicating tall, medium, and 

short regions across the field.  The operator varied the application rate by selecting one 

of three discreet pre-determined application rates corresponding to each height category.  

The Beck (2001) system utilized the HMAP system’s ability to measure plant height in 

real time during the spraying operation and continuously vary PIX® application rates 

based on plant biomass according to the MEPRT relationships described by Landivar 

(1998).   While the real time HMAP system provides a more concrete assessment of 

plant height than the discreet interval system, neither system fully takes into account the 

effects of previous plant growth regulator applications on a site specific basis; tall plants 

and tall vigorously growing plants are treated alike.  It is theorized that if rate of growth 

is considered along with plant height in variable rate application of plant growth 

regulators, both yield and chemical usage can be significantly improved over constant 

rate application.  The HMAP system provides a platform and means to make such 

acquisitions possible. 
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OBJECTIVES 

Hypothesis:  Machine based height sensors can generate spatial maps of plant height 

that can be used to directly monitor the growth and development of cotton and to aid in 

cotton management when used in conjunction with COTMAN, a popular cotton 

management expert system.   

The following objectives will be investigated in order to validate the fore mentioned 

hypothesis: 

1. Utilize machine based height measurements and other precision agriculture data 

sources to optimize in-field plant sampling schemes for COTMAN. 

2. Develop and validate software and methodologies to allow a machine based 

height measurement system to determine cotton rate of growth in real time. 
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PRECISION AGRICULTURE: AN INPUT FOR COTMAN 
 
 
 

The subsections of this article are presented in two parts:  the first three subsections 

are presented and formatted as a journal article manuscript; the final subsection titled 

“Additional Details” contains additional information not included in the journal 

manuscript. 

 

INTRODUCTION 

OVERVIEW 

The determination of field sampling locations for COTMAN software is a highly 

subjective process.   COTMAN provides guidelines for field sampling with respect to 

methods and numbers.  Many producers do not adhere to the guidelines because of 

frequent and intensive manual sampling requirements.  The utility of COTMAN can be 

enhanced by selecting management schemes that address spatial variability present in the 

field and by selecting field sampling schemes that minimize manual sampling 

requirements.  Research was conducted at Texas A&M University (TAMU) in 2003 to 

explore the concept of using machine based height sensors and other precision 

agriculture technologies to aid in selecting optimal management and sampling schemes 

for COTMAN.  Test sites which consisted of production irrigated and dryland fields in 

the coastal plains and Brazos Valley regions of Texas were monitored throughout the 

growing season by COTMAN and a TAMU developed spatial plant height mapping 

system called HMAP.  Regions of each field that continually exhibited height 
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characteristics consistent with the field average were identified from the plant height 

data.  Two sampling locations selected from consistently average height regions within a 

field were able to generate equivalent COTMAN outputs to those generated with two to 

three times as many sampling locations per COTMAN recommendations from the same 

field for all sites considered in this study, irrespective of field size. 

 

BACKGROUND 

COTMAN is a software based decision support system for cotton that uses manually 

collected field data to provide management related feedback to producers.  The utility of 

COTMAN can be maximized by using the least possible labor input to still obtain useful 

and accurate output information.   Maximizing the input to output ratio for COTMAN 

can be accomplished by selecting optimal management and sampling schemes for a 

particular field. 

The optimal management scheme for a particular site depends on many factors 

relating to field conditions and the producer.  In a field scale management scheme, the 

entire field is managed as a single unit and the desired outputs from COTMAN are 

management recommendations that reflect the general condition of the field.  In a sub-

field or site specific management scheme, each field is divided into smaller management 

zones that share similar characteristics and the desired outputs of COTMAN become 

management recommendations for each zone.   

Producers must have knowledge of the amount of developmental variability within a 

field in order to determine whether a field scale or site specific management scheme is 
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best suited.  A variety of tools are available to assess in-field variability.  Some 

commonly available tools include yield maps, aerial photographs, and soil maps.  Other 

tools such as remotely sensed NIR (near infrared) and RGB (Red, Green, Blue) imagery 

or the HMAP plant height measurement system offer alternative methods for assessing 

variability.  The standard deviation of yield or plant height is one measure of the level of 

variability present.  The Normalized Difference Vegetation Index (NDVI) calculated 

from NIR and RGB multi-spectral imagery is an example of another.  Aerial 

photographs collected during bare soil conditions can be used to identify variable soil 

conditions within a field.  While not always definitive, aerial photographs that show 

significant color variation across the field are often indicative of variable growing 

conditions within the field. 

In addition to assessing spatial variability to determine optimal COTMAN 

management schemes, precision agriculture data sources can also be used to aid in 

selecting optimal COTMAN sampling schemes.  An optimal sampling scheme is one 

that will adequately assess the general condition of the management zone (hereafter 

field) with a minimum number of samples.  COTMAN recommends a minimum of four 

sampling locations for all fields and one site for each 4.0 hectares (10 acres) in fields 

larger than 16.2 hectares (40 acres).  This article will present methodologies for spatially 

selecting optimal sampling schemes through the use of precision agriculture tools and a 

geographic information system (GIS). 
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MATERIALS AND METHODS 

Test locations were selected from two distinct Texas growing regions with intense 

cotton production.  One location was part of the Texas A&M University IMPACT 

Center located in Burleson County (Brazos River Valley of south-central Texas).  

Irrigated and dryland sites with .762 m (30 in.) row spacing were originally included 

from this location; however, poor establishment on the dryland site due to unseasonably 

dry conditions after planting negated its use.  The irrigated site utilized a conventional 

center pivot irrigation system with rows oriented radially around the pivot that were 

managed with conventional tillage.  The other location was in Wharton County on the 

coastal plains of south Texas.  Irrigated and dryland sites with 1.016 m (40 in.) row 

spacing were utilized at this location.  The Wharton County irrigated site used a 

conventional center pivot irrigation system coupled with furrow irrigation in corners.  

Straight rows and conventional tillage were used on both the irrigated and dryland fields. 

Four sampling locations were chosen at each site by an experienced COTMAN 

scout.  Two additional sampling locations were selected from the aerial imagery of each 

field in Digital Orthophoto Quarter Quad (DOQQ) format obtained from the Texas 

Natural Resource Information System (TNRIS) database. The additional locations were 

selected by identifying soil color areas not represented by the scout selected locations.   

The latitude and longitude of each sampling location was recorded with a differentially 

corrected Global Positioning System (GPS) receiver, and those same sites were 
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monitored with COTMAN for the entire growing season.  Figure 1 shows the COTMAN 

sampling locations at the IMPACT Center and the DOQQ of the site. 

Each field was monitored per COTMAN recommendations throughout the growing 

season.  The monitoring sites were located by scouts for sampling via handheld 

differentially corrected GPS receivers.  GPS was utilized to ensure that exactly the same 

locations were monitored each time data was collected.  It also made it possible for 

different scouts to monitor the same fields in a consistent manner. 

 
 
 

 
Figure 1: 2003 COTMAN Sampling Locations 
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Plant height was spatially recorded at each test field on approximately a bi-weekly 

basis throughout the growing season using the HMAP system.  The HMAP system 

measures height using an industrial light curtain which consists of two parallel arrays of 

infrared emitters and receivers.  Height is calculated from the number of blocked beams 

in the light curtain in a method described by Searcy and Beck (2000).  The system 

utilized a tractor-based platform until cotton plants began to touch the axles and then 

was transferred onto a high clearance sprayer.  Height was measured across two rows on 

the 1.02 m (40 in.) sites and across 4 rows on the .762 m (30 in.) site, the difference is 

attributed to implement configuration.  Searcy and Beck (2000) verified that HMAP 

produces comparable results when measuring across 2 rows or 4 rows.  Sampling passes 

were conducted every 18.29 m (60 ft) across the field consistent with the boom width of 

the sprayer and representative of routine field operations in production.  

Multi-spectral NIR and RGB imagery was collected during the growing season by 

airplane as weather conditions permitted.  Daily cloud cover made it difficult to collect 

timely high quality aerial imagery in this study; in the 2003 growing season imagery for 

two dates (July 25 and August 8) was obtained.  These dates occurred after cutout (<5 

NAWF) at both sites.  The aerial imagery (one meter resolution) was collected and 

georeferenced by GeoVantage, a commercial aviation company.  All Burleson County 

and Wharton County sites were included in the imagery.  The imagery was post 

processed in GIS to generate maps of NDVI.  Equation 1 was used to calculate NDVI.  

Several measures of NDVI have been suggested in literature; however, the one 
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calculated by Equation 1 is most prevalent (Tucker, 1979; Plant et al., 1999).  Figure 2 

shows NIR imagery and the NDVI map of the IMPACT Center in Burleson County. 

1)  
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)(Re)(Re
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dd

RGBNIR
RGBNIR

NDVI
+

−
=  

Plant height data, field boundaries, DOQQ imagery, multi-spectral imagery, and 

sampling locations were compiled in a GIS for analysis.  Figure 3 shows plant height 

values recorded at the irrigated fields in both Burleson and Wharton counties with the 

HMAP system.  Each plant height data set was processed to identify the average height 

of the field and the standard deviation (σ) of height across the field.  Plant height values 

within a finite range about the field mean were identified as average height locations for 

each sampling date.  The range of height values classified as average varied relative to 

field variability while the number of locations remained constant by consistently 

identifying locations within σ8
1±  of the mean.  Regions within each field that 

consistently (over multiple sampling dates) produced average height locations were 

identified as average height regions.  Average height regions in this study were located 

by identifying (in the GIS) 12.19 m (40 ft) diameter circular regions in the field that 

contained at least one average height value from each date data was collected.  Figure 4 

shows average height locations and average height regions at the IMPACT center.  The 

average height regions identified in Figure 4 are shown for illustrative purposes and do 

not represent the exact size or number of sites in this field. 
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Figure 2: NIR and NDVI Maps 
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Figure 3: Plant Height Maps Created From HMAP Data
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Figure 4: Average Height Locations and Regions 

 

 

COTMAN analysis was conducted for each site in 3 variations using the following 

sample sets:  all sampling locations, two sampling locations located in average height 

regions, single location with greatest variation from mean.  Using all sampling locations 

represents the conventional use of COTMAN with the recommended sampling intensity.  

Using only two sampling sites represents the use of COTMAN with sites identified 

through height maps as representative of the field average.  The single location 

represents the field region with the greatest deviation from the field average.  The three 

nodes above first square and nodes above white flower (NAFS/NAWF) development 
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curves for each site were combined onto a single graphic for comparison.  Figure 6 

shows the NAFS/NAWF plots for the IMPACT center and the irrigated site in Wharton 

County. 

Kerby and Hake (1996) suggested that vegetative growth rate can be determined by 

dividing the change in height over a time period by the change in number of nodes over 

the same time period giving units of length per node.  In this study, rate of growth was 

calculated using Equation 2 giving units of length per day.  Rate of growth maps were 

generated from the HMAP data for each height sampling field pass.  Historical height 

data was interpolated in the GIS to generate a continuous surface of height across the 

field.  A third degree inverse distance weighted (IDW) surface was used in this 

interpolation.  IDW interpolation is widely used in agricultural applications and well 

suited for situations with a large distance between points (Kravchenko, 2003).  Rate of 

growth at each point where height was measured on subsequent field passes was 

calculated using Equation 2.     An example of a ROG map is show in Figure 5. 

2)  
Time

HeightHeight
ROG historicalcurrent −=  

 

RESULTS AND CONCLUSIONS 

The test sites located in Wharton County can be classified as fields with little 

variability.  Both the irrigated and dryland fields had a similar and consistent standard 

deviation of plant height throughout the growing season.  The standard deviation of plant 

height in Wharton County ranged from 7.87 cm (3.1 in.) for the irrigated field early in 

the season to 11.68 cm (4.6 in.) for the dryland field late in the season.  Table 2 
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summarizes the standard deviation of plant height on various dates for the Wharton 

County and Burleson County sites.  Variations in the field that were expected to be 

present, such as the perimeter of the pivot sprinkler and the area not irrigated, are clearly 

evident in both the HMAP data and aerial imagery.  NDVI maps generated from the 

imagery indicate that that the variation is subtle.  Figure 3 clearly shows the boundary of 

the center pivot system. 

Table 2:  Standard Deviation of 2003 Plant Height Data (cm) 

Location Type 05/29/2003 06/10/2003 06/20/2003 07/03/2003 07/09/2003 07/16/2003 
Wharton 
County 

Irrigated 8.84 7.87 -- 8.76 -- -- 

 Dryland 10.24 11.86 -- -- -- -- 
Burleson 
County 

Irrigated -- -- 29.59 -- 30.73 21.84 

 

 
Figure 5: Rate of Growth Map 
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Figure 6: NAFS/NAWF Development Curves for Irrigated Sites  
(triangles indicate rainfall events) 
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The IMPACT Center in Burleson County is an example of a field with significant 

variability.  Variability at this site is clearly visible in the plant height maps, DOQQ 

imagery, NIR imagery and NDVI maps.  The standard deviation of plant height at the 

irrigated Burleson County site was significantly higher than either of the Wharton 

County sites.  The standard deviation ranged from 21.84 cm (8.6 in.) to 30.73 cm (12.1 

in.) during the 2003 growing season.  In addition, other precision agriculture data 

available for this site including yield maps, aerial imagery, soil conductivity maps, and 

soil series maps all indicate significant variability across the field.  The Burleson County 

site would be more accurately managed by COTMAN if divided into smaller 

management regions.  Significant variability is evident in all data sources considered in 

this study.  While the focus of this study was to use the HMAP system in conjunction 

with COTMAN, data from other precision agriculture data sources would have led to 

similar conclusions pertaining to variability in this field. 

The NAFS/NAWF curves for all fields show little difference between using two 

sites in consistently average regions versus using all sampling locations.  There is 

somewhat less difference between the two curves in the Wharton County sites (<2 days 

difference in cutout) where little variability is present across the field compared to the 

Burleson County site (~5 days difference in cutout) with significant variability. It should 

be noted that using all sampling sites included those from the most variable sites and the 

most average.  Therefore it is not surprising that the curve for all samples would fall 

between the curves for “most average” and “most variable”. The management 

recommendations from both SQUAREMAN and BOLLMAN (components of 



 24

COTMAN) are identical for all fields for “all samples” and “two most average” 

sampling strategies.  Conversely, curves generated from a single site with greatest 

deviation from the mean were significantly different from the other two at all sites.  The 

difference is greatest for the Burleson County site which is inherently due to the high 

degree of variability present at the site.    COTMAN generates different management 

recommendations for the Burleson County site using a single site with greatest deviation 

from the mean. 

Rate of growth maps show the same general variability trends as plant height maps, 

NDVI maps, yield maps, and aerial imagery.  Some negative rate of growth values are 

present in all maps generated in this study.  The negative values are generally located in 

areas of least vigor as identified in the NDVI maps.  Fewer negative values are present 

when longer time intervals between height measurements are considered.  Negative rate 

of growth values can be attributed to height measurement error and errors associated 

with surface interpolation in the GIS.  The rate of growth map shown in Figure 5 

contains the largest percentage of negative values of any map generated in this study.  In 

this map, 26% of the calculated rate of growth values are negative; the negative values in 

this map have an average magnitude of -.366 cm/day (-.144 in/day). The rate of growth 

period spans a time period from just before cutout to just after cutout.  The 2003 

COTMAN data from this study showed that cutout in shorter less vigorous regions 

occurred in advance of the rest of the field.  Therefore, the high percentage of negative 

values in this map is most likely the result of height measurement errors amplified by 

little or no change in plant height during the time period due to cutout.  Overall, ROG 
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appears to be a powerful tool with potential to assess vegetative vigor across the field 

and provides information similar to NDVI.  

 

SUMMARY 

COTMAN generates uniquely different management recommendations within a 

particular field when regions of significant variability are considered separately.  One of 

the sites used in this study had significant spatial variability while the other two sites had 

very little variability.  Spatial variability can be quickly assessed by calculating the 

standard deviation of plant height.  Machine measured plant height data can be used to 

identify average height regions which can be used to select optimal COTMAN sampling 

locations.  In all sites considered in this study, irrespective of variability, the same 

management information was obtained from COTMAN by using two carefully selected 

sampling locations in place of many sites as recommended by COTMAN.  Rate of 

growth can be calculated by comparing plant height data from multiple dates.  NDVI 

maps used to assess vegetative vigor show the same general trends as rate of growth 

maps derived from plant height data. 

 

CONCLUSIONS 

This study suggests that COTMAN can be successfully implemented by conducting 

field scouting at significantly less sites than recommended by COTMAN.  Precision 

agriculture and GIS provide a means to design improved COTMAN sampling schemes.  

Reduced field scouting directly translates into less input costs for producers.   
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In this study, rate of growth was calculated by post processing data in a GIS.  

Enhancements currently under way for the HMAP system will make it possible to 

calculate rate of growth in real time.  Future research in conjunction with agronomists to 

develop target rate of growth curves for cotton may allow rate of growth information to 

completely replace a portion of the frequent crop scouting currently required by 

COTMAN.    

 

ADDITIONAL DETAILS 

Plant height data for this research was collected using the HMAP system.  Figure 7 

shows the basic components that make up the system.  The Banner® MINI-ARRAY® 

scans the array at 200 Hz identifying blocked beams on each scan.  HMAP software  

 

DGPS

Parallel arrays of infrared emitters and 
receivers are used to measure plant 
height by monitoring the number of 
blocked beams 

An embedded PC is used to process and 
store plant height and GPS data and to 
perform variable rate chemical 
application when used on a sprayer

A differentially corrected GPS 
receiver is used to associate 
plant height with a specific 
location in the field Real time variable rate PIX 

application based on plant height 
can be controlled by HMAP

WAG® VCD

Banner®
Mini Array

 
Figure 7: Basic Components of the HMAP System 
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determines plant height by building a histogram of incoming blocked beam data.  Plant 

height is calculated as the value half way between 80% of the maximum detected height 

and 20% of the maximum detected height as described by Searcy and Beck (2000).  The 

DGPS receiver used in this study was a Trimble® AgGPS® 114 with stated sub-meter 

accuracy.  The DGPS position is recorded along with calculated plant height once per 

second by the HMAP system.  The platform for the HMAP system is a WAG® Vision 

Computer Display (VCD) (originally developed by Rockwell Collins® as the Vision 

system) which consists of a MS-DOS based industrial PC and LCD display housed in a 

ruggedized enclosure.  The HMAP software is written in Borland® C++.  Technical 

details of select components of the HMAP system relating to height measurement are 

summarized in Table 3. 

 
Table 3: HMAP System Height Measurement Component Summary 

COMPONENT PROPERTY DESCRIPTION 
Model BMEL3016A (Emitter) 

BMRL3016A (Receiver) 
Number of Beams 40 
Beam Spacing 0.75 in 

Banner® MINI-ARRAY® 

Output RS-232 Serial 
Model 114 
Accuracy Sub-meter 
Correction WAAS/EGNOS 
Update Rate 
(Maximum) 

10 Hz 

Trimble® AgGPS® 

Output RS-232 Serial 
Model VCD 
Motherboard Octagon Systems Corp.® 

PC-325R 
CPU 80486SLC 
Platform MS-DOS 

WAG® VCD 

Input (4) DB9 Serial 
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 Spatial data was analyzed using ESRI® ArcGIS Version 8.3.  All data was projected 

to Universal Transverse Mercator, North American Datum 1983 (UTM, NAD83) for 

processing.  COTMAN sampling locations recorded with differentially corrected 

Lowrance® iFinder handheld GPS receivers were converted from NAD (1927) to 

NAD83 using the NADCON conversion. 

 Two different procedures were implemented for identifying average height regions.  

In both procedures, average height locations for each date were identified as previously 

described and exported to a new (ESRI®) shape file consisting only of average height 

locations.  The first method consisted of using the “Select By Location” feature in 

ArcGIS to identify points in other layers (average height locations from other dates) 

within a specified distance of points in the base layer (average height locations from the 

first date).  This method ensured that consistently average height regions contained at 

least one average height location from each date data was collected.  The second method 

involved using a script called “Nearest Feature” downloaded from the ESRI website 

(shareware, available from the author on request) to identify points from the base layer 

that were nearest to points in the other layers.  Points in the base layer closest to points 

the other layers were identified as the centroids of consistently average height regions.  

Both methods produced similar results.  The first method used built-in features of 

ArcGIS and was thus used in analysis of all field data in this experiment.  The second 

method was used primarily to verify the results of the first method and was presented in 

this context as an alternative to ascertain the same information.  The size of an average 

height region was assumed to be a circle with a 12.19 m (40 ft) diameter.  An optimal 
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size for an average height region has not yet been determined by field trials; in this study 

the 12.19 m (40 ft) diameter size provided a small enough area to consistently identify 

plants representative of the field average and was large enough to make locating the 

region and collecting samples convenient.  A detailed summary of the procedure for 

identifying average height regions in ArcGIS 8.3 is included in Appendix B for 

reference. 
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RECOMMENDATIONS FOR FUTURE COTMAN RESEARCH 
 
 
 
 The information obtained from one season worth of plant height and COTMAN data 

collected in this study indicates that field samples collected from two average height 

regions can be used to characterize a field for COTMAN in place of 4 to 6 sites as 

recommended by COTMAN guidelines.  Further studies need to be conducted to verify 

that the relationship between average height regions and plants representative of the field 

average remains valid over multiple growing seasons.  Analysis of cotton yield data has 

shown that yield regions (low, average, and high) generally remain consistent from 

season to season; it is hypothesized that plant height and average height regions follow 

the same pattern.  Future studies could address whether once determined, average height 

regions can be used over multiple seasons to characterize the average conditions of the 

field.  Such knowledge could make it possible for height data to be collected and 

analyzed during a single season and hence, allow producers without continuous access to 

a ground-based height mapping system to experience the same COTMAN sampling 

efficiency improvements as those with access to such a system. 

 This research briefly addressed the concept of selecting appropriate management 

zones for COTMAN.  While it was shown that fields with a high degree of spatial 

variability exhibit large standard deviations of plant height when compared to fields with 

little variability, selecting specific management zones and classifying what constitutes a 

large standard deviation of plant height was not directly addressed.  The development of 
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a decision support system for plant height data that aids in the selection of optimal 

management regions would further expand the utility of plant height data. 

 The concept of monitoring crop growth rate with respect to plant height or plant 

biomass was presented in the Introduction.  In this research, COTMAN was used to 

monitor crop growth rate and plant height was used to aid in selecting optimal sampling 

schemes for COTMAN.  Future research by agronomists could lead to the development 

of target plant height growth curves based on heat unit accumulation and historical 

climatic data similar to those generated by COTMAN which could be combined with 

current plant height data to directly track cotton development.   

 The optimal size for a consistently average height region has not been determined.  

Field trials with average height regions of different sizes would need to be conducted in 

order to define an optimal size.  Regions with the largest possible size to adequately 

represent the field average would be most convenient by providing a large number of 

plants from which crop scouts could select samples.  
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REAL TIME RATE OF GROWTH DETERMINATION 
 
 
 

INTRODUCTION 

The concept of calculating rate of growth from current and historical plant height 

data was presented briefly in the previous article.  Plant height data collected in 2001 

and 2003 was used to validate the feasibility of calculating rate of growth by comparing 

height data from different dates in a GIS.  While the concept seems relatively simple and 

straight forward, many factors are involved that makes it less than trivial.  First, plant 

height data is collected by the sprayer-based HMAP system at discreet points in passes 

separated by 18.29 m (60 ft).  In an ideal model, data would be collected from pass to 

pass at exactly the same points; however, if the implement driver was capable of driving 

down exactly the same path from pass to pass, even the best real time kinematic GPS 

receivers available lack the precision to locate exactly the same point in space twice.  

Further, the HMAP system calculates height by building a histogram of several height 

measurements accumulated over a 1 second time interval and thus, each recorded height 

value is a representation of a small region rather than a single measurement.   This 

makes it necessary to build a continuous surface of historical plant height values from 

which to compare current values.  Second, detecting small changes in plant height is 

difficult due to variable field conditions.  The absolute magnitude of plant height 

changes over a small time interval is finite.  Plant growth regulators and insecticides are 

applied frequently, often on an interval of 7 to14 days.  Variable field conditions such as 

irrigation or tillage, can cause vertical changes for the sprayer greater in magnitude than 
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plant height change on a small time interval.  Factors such as wind or heat can also make 

a difference in height change detection when plants lean or leaves wilt.  Third, inherent 

errors from all of the systems are compounded when comparing data from multiple 

dates.  Each component has an associated error; when data from two dates is compared, 

errors can compound in an unpredictable manner.  Despite these challenges, analysis of 

GIS calculated rate of growth data has shown that the concept is feasible and has the 

ability to accurately identify developmental variability across the field. 

Ultimately, rate of growth data can be used to improve spray efficiency and 

effectiveness, particularly of plant growth regulators.  Post processing plant height data 

in a GIS to determine rate of growth is a reasonable way to validate a concept for 

research purposes; however, to be practical for production, it must be determined 

automatically and in real time.  While post processed data could theoretically be used to 

generate prescription maps for variable rate spraying, it would require twice as many 

field passes; one to measure plant height and one to spray with an intermediate step to 

process the data.  Extra field passes are time consuming, expensive, and unnecessary. 

The HMAP system offers a platform and software structure conducive to calculating 

rate of growth in real time.  The components needed to measure plant height, spatial 

location, and to record data are already in place.  A means to obtain historical plant 

height values at the same locations where current height values are recorded and a 

method to compare the current height values to historical values are the only additional 

functionalities needed to determine rate of growth in real time with the HMAP system.  
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The remainder of this article will detail the development and verification of an enhanced 

version of the HMAP system with the ability to determine rate of growth in real time.  

 

MATERIALS AND METHODS 

ADDITIONAL COMPONENTS 

The basic components of the HMAP system were described in the previous article; 

Figure 7 and Table 3 summarize the basic components of the system.  The VCD offers 

some computational resources for adding additional functionalities to the HMAP system; 

however, CPU usage is nearly maximized by the operations needed to maintain the 

current functionality.  Continually processing a data set of historical height values each 

time current height is measured is computationally intensive and thus an additional CPU 

was added to the system to handle processing the historical height data.  A Microsoft® 

Pocket PC 2002 based Hewlett-Packard® (hereafter, HP) iPAQ® (hereafter, iPAQ) 

model h3950 was selected as the hardware to handle this operation.  A commercially 

available Pocket PC software package called Pocket Spreader v.1.35 (Delta Data 

Systems, Inc., Picayune MS) was selected to handle the data processing.  Pocket 

Spreader is normally used to read prescription maps and control variable rate application 

systems; however, in this application it is used to read prescription maps of historical 

plant height and convey historical height data to the HMAP system.  The iPAQ comes 

equipped with a single serial port while the Pocket Spreader requires two ports, one for 

GPS input and the other for output.  A port expansion pack (HP P\N 173397-002) was 

added to the iPAQ to add a compact flash (CF) PC card slot.  A ruggedized CF serial 
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port card (Socket Communications, Inc., Newark CA) was added to provide the 

additional serial communication port.  A serial “Y” cable was constructed to allow the 

current GPS receiver to communicate simultaneously with both Pocket Spreader and the 

iPAQ at the same time.  The “Y” cable eliminates the positional errors associated with 

using two separate GPS receivers.  Table 4 summarizes the additional hardware and 

software components added to the HMAP system for rate of growth determination.   

Table 4: Summary of Additional Components Added to HMAP for ROG Determination 

COMPONENT ITEM DESCRIPTION 
Model h3950 
Memory 32 MB (ROM) 

64 MB (RAM) 
CPU 400 MHz Intel® 
Platform Pocket PC 2002 

HP iPAQ 

Input (1) DB9 Serial 
(1) USB 

Model 173397-002 HP Expansion Pack 
Input (1) CF 
Model SL2703-138 Socket Communications 

Ruggedized Serial Card Input (1) DB9 Serial 
Version 1.35 
Platform Pocket PC 
Output ASCII String 

Pocket Spreader 

Map File Format *.vaf 
Input (1) DB9 Male Serial “Y” Cable 
Output (1) DB9 Male (Null Modem)

(1) DB9 Female (Standard) 
 

All of the added components with the exception of the “Y” cable were purchased 

complete and required no special modification.  The “Y” cable is unique in that it must 

provide standard RS-232 communication (Rx to Rx and Tx to Tx) between the GPS 

(Data Communications Equipment (DCE) device) and VCD (Data Terminal Equipment 

(DTE) device) and a modified null-modem RS-232 communication (Tx to Rx, Rx to Tx, 
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Request to Send (RTS) to Clear to Send (CTS), and CTS to RTS) between the GPS and 

iPAQ (DTE Device).  Figure 8 shows the pin assignments and wiring schematic for the 

“Y” cable.  

 

1 2 3 4 5

6 7 8 9

1 2 3 4 5

6 7 8 9

54321

9876

54321

9876

DB9 Male to GPS

DB9 Male to iPaqDB9 Female to VCD

Ring IndicatorPin 9
CTSPin 8
RTSPin 7
Data Set ReadyPin 6
GroundPin 5
Terminal ReadyPin 4
TxPin 3
RxPin 2
Carrier DetectPin 1

RS-232 Pin Assignments

Ring IndicatorPin 9
CTSPin 8
RTSPin 7
Data Set ReadyPin 6
GroundPin 5
Terminal ReadyPin 4
TxPin 3
RxPin 2
Carrier DetectPin 1

RS-232 Pin Assignments

 

Figure 8: Serial "Y" Cable Wiring Diagram and Pin Assignments 

 
SOFTWARE CHANGES 
 
 Extensive modifications to the current HMAP software were needed to interpret the 

historical height data, calculate rate of growth, provide an output to the operator, and log 

historical rate of growth and height data.  A brief summary of changes is presented. 

Specific changes are noted in the source code which is available from the author on 

request. 
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First, the current software was upgraded from Borland® Turbo C++ v.1.0 to 

Borland® C++ v.5.2.  While v.5.2 is not current software, it is the last Borland® 

compiler with the ability to generate 16-bit MS DOS code as required by the VCD.  

These changes primarily consisted of changing function calls for serial communication 

routines from CommTools v.1 (Magna Carta Software, Inc., Plano TX) functions to 

CommTools v.3 functions.   

Second, new functions and objects were added to the HMAP code to handle 

requesting new data from the iPAQ and interpreting incoming data.  Pocket Spreader 

believes that it is connected to a Raven® (hereafter Raven) 750 sprayer controller.  

When it receives an “actual rate” string (from the Raven or in this case the VCD) it 

generates and outputs a “rate calibration” string from prescription map data.  New 

functions were developed in HMAP to generate “actual rate” strings and interpret “rate 

calibration” strings.   Table 5 shows the ASCII format of the Raven strings.  Each 

“product” in the “rate calibration” string represents one data layer in the prescription 

map being interpreted by Pocket Spreader.  In HMAP, historical height values are the 

only data layer and are handled as “product 1”.  A false “actual rate” string is sent to the 

iPAQ each time new historical height data value is requested.  New data is requested 

once per second (the current recording rate of HMAP).  An unreasonable value is sent to 

the iPAQ as the false “actual rate” to allow the operator to verify that communication is 

taking place from the VCD to the iPAQ; “actual rate” is displayed on the screen in 

Pocket Spreader (default is 0.0).   A similar check is implemented on the VCD by not 

displaying historical height or rate of growth data unless the iPAQ is connected.  
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Table 5: Raven Strings Used by HMAP 

STRING TYPE ITEM STRING EXAMPLE 
Format $R014,AR,<AR_1>, <AR_2>, 

<AR_3>,<AR_4>,<AR_5><CR><LF> 
Example $R014,AR,500,,,,<CR><LF> 

Actual Rate (AR) 

Interpretation Raven Chip#: 014   Software Revision: D 
Actual Rate: 50.0,0,0,0,0 

Format $R,RC,<RC_1>,<RC_2>,<RC_3>,<RC_4>,
<RC_5><CR><LF> 

Example $R,RC,25,,,,<CR><LF> 

Rate Calibration (RC) 

Interpretation Change Rate to: 2.5,0,0,0,0 
  

Third, user interface, data recording, and calculation functions were updated to 

include historical height and rate of growth data.  When the system detects that both the 

height sensors and iPAQ are connected and transmitting data, rate of growth is 

calculated using Equation 2 (Page 20), historical height and rate of growth are displayed 

on the screen next to current plant height, and historical height and rate of growth are 

stored in the data file along with plant height, GPS coordinates, and other parameters.  

Constant parameters such as the number of days since historical data was recorded (used 

in rate of growth calculation) and the false actual rate value mentioned previously are 

stored in a user updatable initialization (*.ini) file which is automatically loaded at 

startup. 

 Fourth, the data processing program was updated to read the new data file format.  

HMAP data can be recorded in either binary or ASCII formats (user selectable).  The 

binary format is preferred because less memory space is required to store binary data; 

however, it is completely useless without being processed.  Data in either format is 
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recorded in HMAP line by line into a data (*.dat) file that must be interpreted and 

organized into a usable format.  A program called Process (Process.exe, available from 

the author) is used to process recorded (*.dat) data into usable text (*.txt) and comma 

separated variable (*.csv) files.  GIS software can directly read the *.csv file format.  

Changes were implemented to allow Process to read the new data generated by the rate 

of growth and historical height additions.  

 

PREPARING HISTORICAL HEIGHT DATA 

 Before rate of growth can be calculated in HMAP, a preliminary data set of baseline 

height data must be collected during the first field pass of the season.  Once the baseline 

height data is collected, each future field pass can use any previously recorded height 

values from the season as a source of historical height values.  Previous discussion 

addressed the need to convert discreet plant height values into a continuous surface.  It is 

therefore necessary to process historical plant height data into a continuous raster surface 

before attempting to determine rate of growth.  Pocket Spreader reads a raster 

(prescription) map format called VAF (*.vaf).  A GIS application called AGIS (Delta 

Data Systems, Inc., Picayune MS) is the only software package known that is capable of 

producing the VAF format.  Continuous surfaces of 1 m resolution were generated in 

AGIS using a second order IDW interpolation method in this research.  It should be 

noted that a third order IDW was used in GIS analysis of 2003 plant height data.  This is 

due to differences in pass width; the field collected data required more “smoothing” due 

to a larger distance between passes.  Interpolation parameters must change according to 
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the data source, details of the particular parameters used in testing of the real time rate of 

growth system are presented in the next sub-section.  A detailed procedure for creating 

VAF files in AGIS is included in Appendix A for reference.  The VAF file must be 

transferred onto the iPAQ and loaded into Pocket Spreader after it is created in AGIS.  

After a raster map is loaded into Pocket Spreader and the iPAQ, height sensors, and GPS 

are connected to the VCD, the HMAP system is ready to begin collecting and displaying 

height and rate of growth data. 

 

TESTING THE SYSTEM 

 Preliminary testing of the rate of growth capable HMAP system was conducted on a 

test course at the Texas A&M University Agricultural Engineering Research Center in 

February 2004.  The test course consisted of three 14.63 m (48 ft) runs made of 2.44 m 

(8 ft) sections ranging in height from .381 m to .635 m (15 in. to 25 in.) set on concrete 

4.57 m (15 ft) apart.  Figure 9 (not to scale) shows the test course setup.  First, baseline 

height data was recorded.  The varying height sections were assembled as shown in 

Figure 9 with the two shortest sections (same height) at the beginning followed by two 

intermediate sections and the two tallest sections (same height) at the end.  Height was 

recorded on each of the three runs and each pass was made in the same direction at 3 

mph.  A surface of historical height values was generated from the baseline height data 

in AGIS. 



 41

4.57 m 4.57 m14
.6

3 
m

3 2 1

Baseline Height Profile

Changed Height Profile

Start

End
 

Figure 9:  Test Course Setup 

 
A second order IDW interpolation with a 12 m fixed radius of influence was used to 

interpolate a continuous surface at 1 m resolution.  The VAF file created in AGIS was 

loaded onto the iPAQ and into Pocket Spreader.  The height sections were re-arranged to 

the changed height profile shown in Figure 9.  An arbitrary value of 10 days was used as 

the time interval between height measurements.  Data was collected during 10 trials on 

the test course.  Each trial consisted of 3 passes always moving in the same direction as 

the baseline height data was recorded.  The HMAP system was shut down and the data 

card was cleared between trials to ensure that each trial was unique. 

 

DATA PROCESSING 

The recorded data was loaded into ArcGIS for processing.  Data was analyzed in 

two variations: 1) zero height values recorded at the beginning and end of each run 
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(where no height sections were located) were removed from the data set, 2) zero height 

values were included.  Each data set was converted to a raster (ESRI Grid) format for 

GIS analysis.  A new surface was generated from the baseline height data in ArcGIS 

using the same interpolation method and parameters as in AGIS.  This step was 

necessary because the VAF format is not compatible with ArcGIS.  A theoretical height 

change was calculated for each data point by subtracting the raster values from the 

continuous surface of baseline height from the HMAP measured height.  Rate of growth 

is the desired output from this research; however, rate of growth is a relative calculation 

with a magnitude dependent upon the number of days between data sets whereas height 

change is absolute.    The theoretical height change was subtracted from the HMAP 

calculated rate of growth multiplied by 10 (the arbitrary number of days) to identify the 

error in height change estimation associated with each data point. 

The height change error data was exported into the statistical software package 

SPSS for further analysis.  A one way analysis of variance (ANOVA) was conducted to 

determine if the mean error in detected height change was significantly different 

between trials at a 95% confidence interval.  In addition, a Games-Howell multiple 

comparison test was conducted to identify significant differences in means between 

individual trials.  
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RESULTS AND CONCLUSIONS 

 The HMAP system functions well with the added rate of growth determination 

features.  Historical height values displayed on the HMAP screen match values 

displayed on the iPAQ in Pocket Spreader indicating that data is being transferred 

between the two devices accurately and in a timely manner.  The displayed and recorded 

rate of growth values vary as intended relative to height changes detected by the system 

indicating that the HMAP software is working properly. 

 Analysis of data collected on the test course indicates that the system has a mean 

height change detection error of +3.43 cm (+1.35 in.) when zero height values at the 

beginning and end of test runs are removed and 2.36 cm (+0.93 in.) when zero values are 

included.  While the zero values are real values recorded with the system, they only exist 

outside of the test area and do not contribute to the desired rate of growth parameter; 

therefore, only the variation where zero values were removed will be considered 

hereafter.  The ANOVA analysis revealed no significant difference in means (of height 

change detection error) between trials with significance of 0.831 at a 0.05 confidence 

level.  Table 6 contains a statistical summary of the test course data.  The Games-Howell 

multiple comparison test confirmed that the mean height change detection error of each 

individual trial was not significantly different from the mean of any other trial.  Table 7 

shows the significance values from the Games-Howell test.  Very high significance 

values give a strong indication that none of the means are significantly different. 

The height change detection error was somewhat higher than expected.  A variety of 

factors may be contributing to the calculated error.  Test course data was collected using 
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a continuous surface generated in AGIS while the theoretical height change was 

calculated using a continuous surface generated in ArcGIS.  While the IDW 

interpolation parameters were identical and the same set of discreet data was used to 

generate both surfaces, it is probable that the surfaces are not exactly the same due to 

differences in the algorithms between the two GIS packages.  The test course consisted 

of both positive and negative height changes equal in magnitude; thus, the ideal model 

would have a height change detection error of zero.  The positive mean error is a strong 

indicator that the baseline height surfaces may not be exactly the same.  Another 

contributing factor may be the resolution of the rasterized height data; a one-meter 

resolution surface was used in this study.  The HMAP system records rate of growth 

once every second; at 1.34 m/s (3 mph) one to three different height values may be read 

from the one-meter resolution surface while only a single value is recorded.  While 

changes are not generally abrupt on an interpolated surface, this may also be a factor 

contributing to the higher than expected error.  Historical height values output by Pocket 

Spreader have a precision of 1; thus, all values from the continuous surface are subject to 

rounding.  All of the errors are compounded when using a relatively small test course.  

The HMAP system is designed to be used on a field scale. In field conditions, plant 

height normally does not change as abruptly or as frequently as on the test course.  In 

addition, the data sets considered in this study (<50 data points per trial) are extremely 

small compared to field size data sets. 

The largest contributor to the mean height change detection error is most likely the 

difference in interpolated surfaces between AGIS and ArcGIS.  A random sampling of 



 45

like points (1 m x 1 m grid cells) in ArcGIS and AGIS confirmed that interpolated 

values differ slightly between the two surfaces.  Therefore, the true error may actually be 

less than reported in this article.  The high significance value from the ANOVA analysis 

testing for differences between dataset means indicates that the system performs in a 

consistent and repeatable manner.  Even with a mean height change detection error of 

3.43 cm (1.35 in.), the system is still capable of providing useful and timely data.  Future 

field testing will be required to validate the true accuracy and usefulness on a field scale. 

Table 6: Summary of Height Change Detection Error Analysis 
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Table 7:  Significance* Value Summary from Games-Howell Test 

--.992.995>.999>.999.972>.999>.999.984>.99910
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>.999>.999>.999.999-->.999>.999.994>.999>.9996
.972>.999>.999.935>.999-->.999.868>.999>.9995

>.999>.999>.999.999>.999>.999--.996>.999>.9994
>.999.883.935>.999.994.868.996--.858.9913
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>.999>.999>.999.998>.999>.999>.999.991>.999--1
10987654321Trial

*significance values greater than .05 indicate means are not significantly
different at a 95% confidence level

 

 

SUMMARY 

 The concept of rate of growth determination was investigated by processing plant 

height data collected in 2003 in a GIS.  The HMAP system was extended to add the 

functionality to calculate and record rate of growth in real time.  The extended HMAP 

system was tested on a test course to validate function and repeatability.  The accuracy 

of the rate of growth system as determined from test course data was somewhat higher 

than expected but was still within an acceptable range.  Field testing is needed to 

validate the conclusions reached on the test course.  Real time rate of growth 

determination offers a never before available means for monitoring cotton growth and 

development.  It will be left to future research to find uses and applications for the 

technology that has been developed through this research effort. 
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RECOMMENDATIONS FOR FUTURE RATE OF GROWTH RESEARCH 
  
 
 

The HMAP rate of growth system performed relatively well during preliminary 

testing on a test course with solid panels used to simulate plant heights.  Field 

verification will be necessary to determine the accuracy of measuring rate of growth in 

real time in cotton.  Field data will also allow parameters such as the resolution for an 

interpolated surface, interpolation method, and interpolation parameters to be optimized 

for field scale measurement of cotton. 

 Some examples of the potential utility of rate of growth data have been presented in 

the previous articles such as monitoring cotton growth and development and improving 

the efficiency and effectiveness of variable rate plant growth regulator application.  It 

will be left to other engineers and agronomists to further develop applications of real 

time rate of growth and explore the physiological relationships between rate of growth 

and cotton development. 

 When used on a sprayer, the HMAP system is already capable of varying chemical 

application rates in real time based on plant height variation.  Once relationships 

between rate of growth and need for growth regulator have been developed, it will be 

possible to further enhance the HMAP system by using the rate of growth data in 

addition to plant height data to calculate application rates.  In addition, the iPAQ and 

Pocket Spreader software make it possible to read multiple prescription map layers at the 

same time (up to 5 layers).  Refinements to the MEPRT program which currently uses 

only an average (field average) value of previous growth regulator could allow site 
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specific historical application data to be used when calculating applications rates.  Other 

prescription map layers such as management zones where no growth regulator is desired 

could be added as well and used to turn the spraying system on and off automatically.  
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SUMMARY AND CONCLUSIONS 
 
 
 

SUMMARY 

The HMAP system, which uses machine based height sensors and a differentially 

corrected GPS receiver to spatially map plant height, was used to map cotton height at 

three test sites located in two distinct Texas growing regions during the 2003 growing 

season.  The same sites were monitored via field collected data using the COTMAN 

expert system.  Regions of each field that produced plants with a height equal to the field 

average on every field pass were identified and classified as average height regions.  

Field data collected from two average height region sampling locations was able to 

generate an equivalent COTMAN output as two to three times as many sites selected per 

COTMAN recommendations at all sites included in this study.  A high degree of spatial 

variability within fields can be indicative of a need for site specific management.  Spatial 

variability was evaluated by the standard deviation of plant height in this study.  Fields 

with a large standard deviation of plant height also showed significant variability in 

NDVI maps generated from remotely sensed imagery. 

Plant height data collected in 2003 was used to generate rate of growth maps in a 

GIS by comparing height measurements from multiple dates.  This process requires the 

generation of a continuous surface of historical height values due to the fact that the 

HMAP system records height at discreet locations.  Rate of growth maps were compared 

to NDVI maps which showed that high and low rate of growth values were closely 

aligned with high and low NDVI values. 
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The HMAP system was extended to calculate rate of growth in real time.  This was 

accomplished by integrating a Pocket PC based application capable of reading rasterized 

prescription maps of historical plant height values into the current HMAP system.  

Function of HMAP rate of growth system was verified on a test course consisting of 

panels of varying height.  Statistical analysis of data collected on the test course revealed 

that the system performed consistently and in a repeatable manner.   

 

CONCLUSIONS 

1. Manual field sampling for COTMAN can be significantly reduced by selecting 

sampling locations from consistently average height regions. 

2. Spatial variability within a field can be characterized by the standard deviation of 

plant height. 

3. Vegetative vigor can be assessed by creating rate of growth maps from plant 

height data collected at different times. 

4. The HMAP system can be used to calculate rate of growth in real time by 

comparing current height measurements to historical height values. 
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APPENDIX A 
  
 
 
PREPARING PRESCRIPTION MAPS OF HISTORICAL PLANT HEIGHT FOR 

USE WITH HMAP
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PREPARING PRESCRIPTION MAPS OF HISTORICAL PLANT HEIGHT FOR 

USE WITH HMAP 

 
 
INTRODUCTION 

 
Historical plant height data must be converted to prescription map format prior to 

being used with Pocket Spreader and the HMAP system for ROG calculation.  The 
following procedure describes the process of preparing prescription maps in detail.  
Similar procedures can be implemented with other data types to generate prescription 
maps of other parameters. Pocket Spreader is part of the Delta Data Systems (DDS) 
family of products.  Currently, AGIS is the only software known to generate the VAF 
file format required by Pocket Spreader.  The main focus of this discussion will be on 
using AGIS to prepare prescription maps.  Because of limited functionality in AGIS, 
some procedures will also be described for ESRI ArcGIS 8.3. 
 
FORMATTING DATA 
 

Generating a text file or spreadsheet from raw HMAP data must be conducted prior 
to creating a prescription map of historical plant height.  Software has been developed to 
convert HMAP data into a CSV format for GIS compatibility.  A DOS based application 
called Process (available from the author) can be used to process binary data into 
comma separated text and GIS formatted text.  The user interface for Process is simple 
and self explanatory.   Currently, Process is configured to generate an ArcGIS 
compatible CSV format; slight modification of the CSV file is necessary for AGIS 
compatibility.  The required CSV formats for ArcGIS and AGIS are described below. 
 
ArcGIS allows comma separated “X,Y” data to be imported in the following format 
where at least two variables represent the X and Y coordinates: 
 
Line 0:  var1_name,var2_name,varN_name <CR> 
Line 1:  var1_1,var2_1,varN_1<CR> 
Line 2:  var1_2,var2_2,varN_2<CR> 
Line N:  var1_N,var2_N,varN_N<CR>    
 
AGIS allows “point” data to be imported in several formats including comma separated 
variable format and Microsoft Excel spreadsheet format.  The comma separated variable 
format for AGIS has the following format where at least 2 variables represent the X and 
Y coordinates: 
 
Line 0:  var1_1,var2_1,varN_1<CR> 
Line 1:  var1_2,var2_2,varN_2<CR> 
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Line N:  var1_N,var2_N,varN_N<CR> 
 

The main difference between ArcGIS and AGIS formats is the absence of the first 
line containing variable names in the AGIS format.  AGIS also allows data to be 
imported as Excel spreadsheet data.  Comma separated text files can be easily imported 
into Excel and quickly modified to conform to the AGIS format and saved as spreadsheet 
(.xls) files.  The limitations of Excel are that data sets are limited to 60,000 lines and the 
software functions at a reduced speed when working with large data sets.  Figure A1 
shows an acceptable Excel format.  When using Excel spreadsheets in AGIS it is 
acceptable to have variable names in the first row while when using text files it is not. 

  

 
Figure A10: Excel Spreadsheet Format for AGIS 

 
 
PREPARING DATA LAYERS  
 

Prescription maps are created from interpolated surfaces generated from discreet data 
points.  It is important for the interpolated surfaces to be contained within a field 
boundary because the accuracy of such a surface rapidly deteriorates when data points 
do not exist.  ArcGIS was used in this research to create field boundaries.  The following 
procedure can be used in ArcGIS to define field boundaries: 

 
1) Load spatial reference data.  This defines the projection and datum for the data 

layer in the map.  Plant height data, aerial imagery, yield data, data points 
collected with a handheld GPS receiver or any other available data source can be 
used for this purpose.  Load such data sources into a new map in ArcGIS. 

 
2) Create new shape file.  Before a field boundary can be drawn, it is necessary to 

define a shape file.  This is accomplished using ArcCatalog.  Open ArcCatalog 
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and in the desired directory click File -> New  -> Shapefile which opens a 
“Create New Shapefile” dialog as shown in Figure A2.  Enter a Name and select 
the Polygon Feature Type.  Click the Edit button and define an appropriate 
coordinate system.  This process is simplified if the desired coordinate system 
matches that of an existing data source.  In this case select Import and select the 
data source from the directory.  Otherwise, choose Select and follow the menus 
to select the desired coordinate system.  Once the coordinate system has been 
defined, click OK to complete the shape file definition.  

 

 
Figure A11: New Shapefile Dialog 

 
3) Load new shapefile into ArcGIS.  Click File -> Add Data or use the Add Data 

Button  and select the newly created shape file. 
 

4) Sketch the field boundary.  Ensure that the “Editor” toolbar is displayed and click 
Editor -> Start Editing.  Ensure that the Target: selection is the new shape file.  
Ensure that the Task: is Create New Feature.  Select the Sketch tool  and 
sketch the field boundary.  When the boundary is complete, double click to 
complete the shape.  If several fields are to be included in the data set, multiple 
polygons can be sketched. 

 
5) Save the field boundary and export shape file.  Click Editor -> Stop Editing and 

when prompted Save Edits.  This shape file is normally ready to be used by other 
applications; however, to guarantee it, the field boundary should be exported as a 
new shape file.  Right click on the field boundary in the Table of Contents and 
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click Data -> Export Data and save the new shape file to the desired location with 
the same coordinate system as the layer’s source data. 

 
ASSEMBLING DATA IN AGIS 
 

Once a coordinate system has been defined in AGIS, it is not possible to change it in 
the future as is common practice in ArcGIS.  Therefore, it is critically important to define 
the correct coordinate system when a new GIS is assembled.  Much of the publicly 
available data sources in Texas such as DOQQ imagery use UTM Zone 14N NAD83 
which conforms to the datum and projection used for the majority of GIS analysis in this 
research.  The following procedure describes the process for creating establishing a 
coordinate system and loading data layers in AGIS: 

 
1) Create Grower.  Click Data -> Create Grower and enter a name.  The term 

“grower” is analogous to “client” used in many other farming specific GIS 
software. 

  
2) Create Farm and establish coordinate system.  Click Data -> Create Farm and 

enter a name.  Each farm can contain many fields.  Click Next and select an 
appropriate season.  Click Next and choose an appropriate pixel resolution.  The 
default is a 5 meter by 5 meter resolution; however, a resolution appropriate for 
the data should be selected.  Since the prescription map will ultimately be used 
with a Pocket PC where storage capacity is limited, a resolution no greater than 
2.5 meters by 2.5 meters is recommended.  Click Next and the projection dialog 
box will appear.  Uncheck the box next to “Determine UTM zone from incoming 
field collected data”.  The default is UTM Zone 15N WGS 1984.     If the desired 
coordinate system is different from the default, click Change Projection and 
select the desired datum and projection.  Click Finish to complete the farm 
definition. 

   
3) Import field boundary shape file.  Click Tools -> Import Drawing -> Shape.  This 

will launch the shape file import wizard.  Select the field boundary created in 
ArcGIS (*.shx).  Click Next and a projection dialog will open.  Since AGIS does 
not recognize the full ESRI shape file format (*.shp) the projection information 
will have to be redefined.  Click Select Projection and select the appropriate 
coordinate system for the field boundary.  This must be the same datum and 
projection used previously in ArcGIS but does not have to be the same as the 
AGIS datum and projection; AGIS will project the selected coordinate system 
onto the Farm projection automatically.  Click Next and select or create an 
appropriate layer and Field.  Click Next and accept the default drawing file.  
Click Finish and the field boundary will be added as a layer.  In order to display 
the field boundary, click the check box next to the layer name in the table of 
contents and click Apply.   
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USING INTERPOLATION TO GENERATE A CONTINUOUS SURFACE IN AGIS 
 

Once the field boundary has been added to AGIS, it is possible to create an 
interpolated surface of plant height.  The interpolation capabilities of AGIS are 
somewhat limiting; however, Inverse Distance Weighted (IDW) interpolation has been 
shown to produce acceptable accuracy.  The following procedure describes the 
methodology for interpolating a continuous surface of plant height from discreet plant 
height data points in AGIS: 

 
1) Launch the surface generator and define the field boundary.  Click Tools -> 

Surface Generator and a surface generator application will appear.  Within 
the application click Surface -> Boundary Objects and select the field 
boundary from the image.  The color of the field boundary will change from 
blue to red when selected.  Right click away from the boundary to end the 
selection process. 

 
2) Import discreet data.  As stated previously, point data can be imported into 

AGIS in several formats including text files and Excel spreadsheets.  The 
Excel method is described here; however, the text file method is nearly 
identical.  Click File -> Point File -> Excel (.xls) file and select the Excel 
spreadsheet file and worksheet that contain the plant height data.  Deselect 
the box next to “First Row Contains Column Headings” if the spreadsheet 
was prepared using the methodology previously described.  Click OK and 
select the appropriate datum and projection for the point data.  Click Finish to 
launch the XLS Vertex Parameters dialog.  Select the appropriate field names 
for the X and Y coordinates where, F1, F2, ..., FN correspond to the columns 
of the spreadsheet.  Select the Z coordinate as the column that corresponds to 
the plant height data.  Click OK, accept the default drawing file parameters 
and click OK to complete the import process. 

 
3) Generate continuous surface of plant height.  Click Surface -> Moving 

Average and select Inverse Distance Average (the default) and an appropriate 
decay constant and radius of influence.  Click OK to launch the output file 
dialog.  De-select the check box next to “Test” as surfaces generated in the 
test mode cannot be used later to create prescription maps.  Select the 
appropriate resolution, Field Name, and Season and check the box next to 
“Preview Surface”.  A completed dialog box is shown in Figure A3.  Click 
OK and approve the default surface channel selections in the dialog box.  
Click OK to accept the surface shown in the preview.  The preview surface is 
not bound by the field boundary and is not in color; this will change after 
approving the surface build.  Click File -> Exit to leave the surface generator 
application.  Check the box next to the newly created layer in the table of 
contents and click Apply to display the interpolated surface.  
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Figure A12: Completed Output File Dialog 

 
CREATING A PRESCRIPTION MAP IN VAF FORMAT 
 

After a continuous surface has been interpolated, it is necessary to create a 
“Treatment” map in VAF (*.vaf) format to be used in Pocket Spreader.  The following 
procedure can be used to generate a “Treatment” map in AGIS: 
 

1) Define Equation.  Click Analysis ->  Treatment.  This will launch a treatment 
dialog.  Here it is necessary to define or select an existing treatment equation.  
For the purposes of historical plant height, this is not very important as the 
interpolated surface pixel values are used directly to calculate the “Treatment”.  
In other cases, it may be necessary to equate application (“Treatment”) rate based 
on multiple map layers.  For historical height, either define a new equation by 
clicking Add Equation… (necessary the first time a treatment map is generated in 
a new map layer) and follow the dialog or select an existing equation from the 
list.  Click Next.  This will prompt the dialog shown in Figure A4.  Here it is 
necessary to select a product to apply.  If no product has been previously defined, 
exit the dialog, follow the procedure below, and start over at 1); otherwise, skip 
ahead to step 2. 
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FigureA13: Treatment Product Info Dialog 

 
 

a) Open the “product” database.  Click Tools -> Processing Databases -> 
EPA…  This will launch a Database Editor dialog shown in Figure A5. 

 

b) Add a new p
product dial

 
c) Define a new

either solid 
must be one

g 
Figure A14: Database Editor Dialo
 
roduct.  Click Records -> Add.  This will launch a new 

og. 

 product.  Even though plant height does not conform to 
or liquid, chose one or the other in the PRODTYPE field (it 
 or the other in order for the software to work).  Enter a name 
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and alias in the CHEMNAME and ALIAS fields respectively.  Enter a 
default rate in the DEF_RATE field.  This should be something like 0.0 
or 99.99 that can be easily identified in a data set in the event data is 
missing.  There is no selection for units of height in the UNITS field so 
select anything here (oz/ac used in this research).  The other parameters 
are not required so leave them blank.  A completed new product dialog is 
shown in Figure A6.   

 

 
Figure A15: New Product Dialog 

 
d) Save and Exit.  Click File -> Save and File -> Exit to leave the dialog. 

 
2) Enter treatment equation.  Highlight the desired product (the one created for plant 

height) and click Next.  This will launch the Equation Editor dialog shown in 
Figure A7.  Complete the dialog as shown in Figure A7.  Select the “Image 
Layer” that corresponds to the IDW surface of plant height.  Click Rate= and 
Apply Variable.  Add a “;” at the end of the line.  Without the “;” the equation 
will not work. 

 
3) Complete the treatment map.  Click Next in the Equation Editor.  Be sure that 

“Process equations” is selected in the ensuing dialog and click Next.  If prompted 
to save the equation, enter a name and click OK.  This will launch a Process 
Treatment Equations dialog.  Highlight the saved equation and click Finish.  A 
Select Treatment Image File dialog will appear.  Select a “Field” and “Layer” 
and de-select “Test” and click OK.  The new treatment will be added to the map.  
To display, click the box next to the layer and click Apply to update the display.  
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Figure A16: Equation Editor Dialog 

 
4) Export VAF file.  Right click on the treatment in the Table of Contents and select 

Files… De-select all except the “Treatment” corresponding to plant height.  If 
more than one layer is desired in the prescription map, treatments must be 
merged together using Analysis -> Merge treatments; for historical plant height 
only one treatment is desired.  Click Tools -> Export Image… -> VAF.  Enter a 
name for the VAF file and click OK. 

 
USING POCKET SPREADER 
 

The newly created VAF file must be transferred onto the iPAQ before Pocket 
Spreader can begin transmitting historical plant height data to HMAP.  This can be 
accomplished using Microsoft ActiveSync.  The VAF file should be stored in a \My 
Documents\Pocket_Spreader directory on the iPAQ.  This directory is also used by 
Pocket Spreader to store “as applied” data files.  These files have the same name as the 
corresponding VAF file with a “_Channel1” at the end and must be deleted periodically 
to conserve memory on the iPAQ. 

Pocket Spreader has a very simple interface and a limited number of user 
changeable parameters.  The “GPS Options…” and “Controller Options…” should be 
configured for the corresponding devices.  In the setup used in this research, GPS is 
connected to COM1 at 4800 baud and the VCD is connected to COM6 at 9600 baud.   
When the system is properly configured a VAF file can be loaded by clicking File -> 
Open and selecting the appropriate file.  After the desired VAF file is open and the 
prescription map is visible on the screen, connect to the GPS by clicking File -> 
Connect.  If the received GPS data is valid, a red dot will appear on the map and blink at 
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the current location.  To begin transmitting data to HMAP, click File -> Start.  This will 
also trigger Pocket Spreader to begin recording data.  When finished measuring rate of 
growth with HMAP, stop the data transmition and recording by clicking File -> Stop.  
Click File -> Connect to disconnect from the GPS and File -> Exit to leave the program. 
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APPENDIX B 
 
 
 

IDENTIFYING AVERAGE HEIGHT REGIONS IN PLANT HEIGHT DATA 

USING ARCGIS
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IDENTIFYING AVERAGE HEIGHT REGIONS IN PLANT HEIGHT DATA 

USING ARCGIS 

 
INTRODUCTION 
 

Two basic steps are required to identify consistently average height regions in 
HMAP plant height data.  First, points from each height data set within 1/8 standard 
deviation of the field average must be identified as average height locations.  Second, 
points from consecutive dates within 40 feet of average height locations from all other 
dates must be identified.  A variety of methods in GIS can be used to accomplish this 
task.  Two methods were discussed briefly in previous articles of this thesis.  The 
method using standard ESRI ArcGIS functions requires the least data manipulation and 
was the used for all data analysis in this research.  This method is described in detail in 
this article.   
 
IDENTIFYING AVERAGE HEIGHT LOCATIONS 
 
 A basic statistical analysis of plant height values is required to identify the field 
average (mean) and standard deviation.  This analysis can be conducted prior to loading 
height data into ArcGIS or within ArcGIS.  It is assumed that identifying these basic 
statistical parameters is simplistic; thus, such methods will not be discussed in this 
article.  Average height locations can be identified using the following procedure: 
 

1) Add “XY” data to ArcGIS and export a shape file.  Click Tools -> Add XY data.  
Select the desired CSV text file and identify the fields in the dataset that 
correspond to the X and Y coordinates.  Click OK and the “Event” data will be 
added to the map.  Export the “Event” data into a shape file by right clicking on 
the newly added “Event” in the Table of Contents and selecting Data -> Export 
Data.  In the ensuing dialog, select “Same as data layer” for Coordinate System 
and click OK when prompted to add a new layer to the map.  Repeat this process 
for each plant height data set. 

 
2) Select points within 1/8 standard deviation of the mean.  Click Selection -> 

Select by Attributes.  This will launch the select by attributes dialog.  Develop an 
equation that describes points within 1/8 standard deviation of the mean.  The 
selected “Layer” should correspond to the desired plant height data set.  The 
equation should reference the field in the dataset corresponding plant height.  A 
sample equation and is shown in Figure A8.  Click Apply and OK.  This will 
highlight all points in the dataset that conform to the equation.  Export the 
selected data points into a new shape file by right clicking on the plant height 
data shape file in the Table of Contents and selecting Data -> Export Data.  In the 
ensuing dialog, make sure that “Selected Features” is selected, click OK, and 
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click OK when prompted to add a new layer to the map.  Repeat this process for 
each plant height data set. 

 

 
Figure A17: Sample Average Height Location Equation 

  
IDENTIFYING AVERAGE HEIGHT REGIONS 
 

An average height region is defined in this research as a circular region 40 feet in 
diameter that contains at least one average height location from every date plant height 
data was collected.  The GIS may identify several locations in the field that conform to 
this criterion; however, it was shown that only two average height sampling regions are 
needed to characterize the general condition of the field.  If more than two average 
height regions are identified, any two sites can equally characterize the field; therefore 
the most accessible sites can be selected from the identified sites.  Average height 
regions can be identified using the following procedure: 
 

1) Identify average height locations from the first date within 40 feet of average 
height locations from all other dates.  Click Selection -> Select by Location.  
This will launch the Select by Location dialog.  In the “I want to” field select 
“select features from”.  In the “the following layers” field select the average 
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height location shape file from the first date.  In the “that” field select “are within 
a distance of”. In the “the features of this layer” field select the average height 
location shape file from the second date.  In the “of” field enter 40.0 and select 
“feet”.  A completed dialog is shown in Figure A9.  Click Apply and the average 
height locations that meet the criterion will be highlighted.  Do not click Close 
until completing step 2. 

 

 
Figure A18: Completed Select by Location Dialog 

 
2) Repeat the Select by Location procedure for all remaining dates after the second 

date.  With the Select by Location dialog still open from step 1, change “I want 
to” from “select features from” to “select from the currently selected features in” 
and change “the features in this layer” to the average height location shape file 
from the next date.  Click Apply and repeat this procedure for all dates.  When 
finished, click Close to return to the map. 

 
3) Create a new shape file to identify the center of each average height region.  

Right click on the average height location shape file from the first date and select 
Data -> Export Data.  In the ensuing dialog, make sure that “Selected Features” 
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is selected, click OK, and click OK when prompted to add a new layer to the 
map. 

 
4) Create average height regions.  This step is necessary only to graphically display 

average height regions on the map.  This can be accomplished using the Buffer 
Wizard.  Click Tools -> Buffer Wizard.  In the ensuing dialog, select the shape 
file that contains the center of each average height region.  Click Next.  Select 
“At a specified distance” and enter 40 feet.  Click Next and select No for 
“Dissolve barriers between”.  Click Finish and the average height regions will be 
displayed on the map. 

  



 70

VITA 
 
 
 

David William Geiger 
8315 194th Avenue 
Ottumwa, IA 52501 

 
 
1979    Born March 27 in Bryan, Texas. 
 
1997    Graduated from Ames High School, Ames, Iowa. 
 
1997-99 Studied Mechanical Engineering at The University of Iowa, Iowa City, 

Iowa. 
 
1998-02 Participated in coop program with John Deere, Ottumwa, Iowa. 
 
2002 B.S. with distinction, Agricultural Engineering, Iowa State University, 

Ames, Iowa. 
 
2002-04 Graduate Assistant, Department of Biological and Agricultural 

Engineering, Texas A&M University, College Station, Texas. 
 
2004 M.S., Biological and Agricultural Engineering, Texas A&M University, 

College Station, Texas. 
 

2004     Returned to John Deere Ottumwa Works as a full time engineer. 
 


